
MAKING 

SCIENTIFIC 

FIGURES WITH 

AFFINITY 

PHOTO

(OR PHOTOSHOP)



In this tutorial, you’ll learn 

tools for making elements of 

a scientific figure.

This, however, won’t teach 

you what makes a good

scientific figure. You need to 

learn that on your own.



Performance issues?

Edit > Preferences > Performance > Uncheck Enable OpenGL compute acceleration



Document setup



Creating a new figure

File > New …

File > New From Clipboard

Useful if you have a figure already 

copied to your clipboard.



DPI only really matters 

when working for 

print/publication.

What’s more 

important is that you 

have enough pixels, so 

your figures don’t look 

fuzzy.



1. Set documents 

units to inches.

2. Set width to 3.5 in.

3. Set page height.

Let’s create a single-

column figure preset.



Embedded: stores images within in your 

document.

Pros: Directly editable

Cons: Takes up more file space

Image Placement Policy

How the program decides 

to treat images you place 

into your document.

Linked: links to the image on your computer.

Pros: Saves space, image changes outside Affinity 

photo are updated.

Cons: Moving or deleting the image causes errors



Color format

The color space we work 

in.



Color format: RGB or CMYK?

1. RGB – for digital and print figures.

Pros:

• Vibrant color range

Cons:

• Colors on screen don’t match what’s printed

2. CMYK – for print-only figures.

Pros:

• Closer idea of printed colors

Cons:

• Less vibrant colors

Since papers and presentations are mostly digital, default to RGB.



Color

Keep the defaults and 

check transparent 

background.

RGB/8 is satisfactory for our needs. If you’re curious about RGB/16 or RGB/32, check out http://perberntsen.com/misc/technical/digitalimage.php

http://perberntsen.com/misc/technical/digitalimage.php


1. Click + to add 

this as a new 

preset.

2. Right click to 

rename this 

preset

3. Click Create to 

begin.



Toolbars



Navigation

Colors

Layers



Placing an image



1. File > Place … 2. Select

“the_great_tit.jpg”



3. Click once on 

the document to 

place it.



Navigation:

Three ways to pan/zoom!

1. Use the Navigator panel

• Type or use the scrub 
bar to adjust zoom.

• Click and drag on the 
document preview

2. Use the View Tool [H] and 

Zoom tool [Z] located on 

the left toolbar.

3. Shortcuts:

Zoom in Ctrl + =

Zoom out Ctrl + -

View whole 

document
Ctrl + 0

Pan

Hold Space

while clicking 

and dragging



Creating a fill 
layer as a 

background



1. Layer > New Fill Layer



Move layer 

underneath bird 

layer. Rename by 

clicking its name.

Change the color of 

the fill layer in the 

Color panel.



Practice placing an 

image by giving our 

bird a hat.

This time, try placing 

an image by clicking 

and dragging.



Adjust the hat with 

the Move tool [V].

Look at the bottom status bar for tool hints.



Using layer effects 
to outline objects



1. With the hat layer 

selected, click fx in 

the layer panel



1. Check and select 

Outline. 2. Increase the 

radius.



Removing 
backgrounds

- PART 1 -
Flood Select &
Mask Layers



Pick and place a left 

arm into the 

document.



1. Click the Flood 

Select Tool [W] 2. Click on the white 

background we want 

to erase to select it.

3. Invert your 

selection with

Ctrl + Shift + I.

You should now see 

the arm is selected.



Click on the Mask 

Layer button.



Whatever was selected is 

now visible while 

everything not selected is 

now masked.

Notice a new mask 

layer under your “left 

arm” layer.



If you have any errors, you 

can adjust it by painting 

on the mask, using

Brush Tool [B]

&

Eraser Tool [E]

Make sure you select 

the mask layer

To show the image, 

paint with white.

To hide the image, use 

the eraser tool or 

paint with black.

I’m painting in white to 

fill in the cell phone.



WHY USE MASKS?

Masks are non-destructive editing, meaning if you 
want to revert a change, you can easily do it.

If you erase the image directly instead of the mask, 
there’s no way to get it back except by undo-ing, 
which can get impossible after a while.



Use the Move Tool [V] to 

move and adjust the left 

arm to your liking.



Selection shortcuts

Select all Ctrl + A

Deselect all Ctrl + D

Invert Selection Ctrl + Shift + I

Select all pixels in a layer Ctrl + Click layer thumbnail



Removing 
backgrounds

- PART 2 -
Lasso Select &

Quick Mask Mode



1. Choose and place a 

right arm into your 

document.

2. Select the

Lasso Tool [L]



There are three modes 

to the Lasso Tool.

1. Freehand

Not recommended 

unless you have a 

touchscreen or tablet.

2. Polyline

Creates a polygon with 

vertices at your click 

points.

3. Magnetic

Draws a selection line 

between areas of high 

contrast.

Let’s use the 

Magnetic mode.



1. Click somewhere 

on the arm to start.

2. Slowly, trace around the 

path of the arm with your 

cursor.

You will see the selection line 

“stick” to the outline.

3. When you are done, click 

your starting point to close 

the loop. Now you have the 

arm selected.

But wait! It’s not 

perfect! How do I fix 

this?



Enter Quick Mask

mode by hitting Q.

Red areas indicate 

areas that are NOT 

selected.

Use the Paint Brush 

Tool [B] to color in 

areas I want to select.

The Eraser Tool [E] 

masks areas I don’t 

want to select.

When satisfied, exit 

quick mask mode by 

pressing Q again. 

You should see your 

selection has been 

fixed!



Create another mask 

layer from your 

selection.

Practice resizing and 

arranging the layers with 

the Move Tool [V] so the 

arm is in the spot you want.



Changing colors 
with adjustment 

layers



Let’s give our bird a 

shirt. Place the 

“bird_shirt.png” onto 

our bird.

Resize and place 

under the arm layer 

but above the bird 

layer.



Let’s change the shirt 

color with an 

adjustment layer.

1. Press Ctrl + Shift + U to create 

a new HSL shift adjustment layer.
(Hue, Saturation, Luminosity)

2. Play with the 

sliders until you get 

the color you want



Oh no! This changes 

our WHOLE image.

Not to fear. Right 

click our adjustment 

layer and click

“Mask to Below”

This makes the 

“bird_shirt” layer act 

like a mask for our 

HSL layer.



Drawing and 
erasing



Create a new pixel 

layer.

Layer > New Layer…

Or click the 

checkerboard icon in 

the Layer panel.



1. Select Paint Brush 

Tool [B]

2. Adjust brush options in the above toolbar:

• Width: Diameter of brush

• Opacity: Transparency of brush

• Hardness: Controls the hardness or softness of the edges on the 
brush stroke

The attribute you will change the most is width.

3. Select Erase Brush Tool [E] for same 

options… but erasing



Click on Brushes in 

the Color panel to 

access a variety of 

brush types.

The most useful ones 

for scientific figures 

are going to be the 

Basic set.



Drawing tips

1. When drawing with a mouse, zoom in and go slowly.

2. For straight lines

• Click once at your starting position.

• Hold shift, then click & release at your ending position.

3. For perfectly horizontal/vertical lines

• Click and hold

• Hold shift, then drag your cursor vertically/horizontally.

• Release when done!



Layer 
management



Our bird is complete. 

Let’s group all the 

layers together.

Select all the layers 

that belong to the 

bird, then click the 

folder icon at the 

bottom of the Layer 

panel.



You can also color-

code layers for your 

own reference.

Right-click the layer 

and pick the color 

you want.



We can apply layer 

effects to whole layer 

groups as well.

Let’s apply an outer 

glow. Play with the 

settings.

Example settings

Blend mode: Normal

Opacity: 100%

Radius: 18.5 px

Intensity: 19%



Working with 
shapes and 

vectors



Let’s create a pop-

out bubble of 

something our 

bird is thinking.

Place the pasta 

image (or any other 

image you’d like) into 

the document.



Select the shape 

tool. You can click 

and hold to pick 

what kind of 

shape you want.

Click and drag to 

create the shape. 

Place the shape over 

your image.



Right click the shape 

layer and select

Mask to Below



Practice applying 

layer effects. Here, 

I’m adding another 

outer glow.



Creating a 
gradient pop-out 

effect



1. Use the trapezoid 

tool to draw a 

trapezoid.

2. At the top, click on 

fill and select 

gradient.

3. Change one end of 

the gradient to have 

0% opacity.



1. Use the Move Tool

to adjust the position 

and orientation.

2. To change the 

shape in detail, click

Convert to Curves



1. Click the

Node Tool [P]

Now you can click 

and drag each corner 

to reshape the 

trapezoid.

Let’s move this layer 

under our pasta.



1. Click the

Gradient Tool [G]

2. Click and drag the 

dots to adjust the 

orientation of the 

gradient.

You can also change the gradient 

type in this upper toolbar.



Lines, including 
dashed and 

arrows



1. Use the

Pen Tool [P]

2. Draw a 

straight line by 

clicking at the 

start and end 

points.



1. Change stroke 

to black.
2. Click the 

button with the 

line and “pt”

3. Adjust options



Creating dotted lines and arrows

1. On the upper toolbar, click the box 

with a line and “0 pt”.

2. Under Style, click the dotted line.

3. Adjust the Width to your satisfaction.

Dash:

• 1st number: Ratio of dash length

• 2nd number: Ratio of space between 

dashes

You won’t need the 3rd and 4th number.



Creating dotted lines and arrows

Cap, Join, and Align 

determine how Affinity 

draws the line on your 

path.

Use this panel to adjust 

arrow heads.



Text!



1. Select the Text 

Tool [T]

2. Type!

3. More options 

if you click the 

Character button



Highlight 

characters to 

change their 

aspects uniquely.

Unfortunately, the super/subscript are 

unreliable in Affinity Photo, and ugly in 

Photoshop.

A workaround:

1. Reduce the super/subscript text by 2 pts.

2. Change the vertical position of the text by 

+2 pt/-2 pt.



Group the arrow and 

text layers and add a 

white outline!



Alignment and & 
Guides



When you select two or more objects, you can 

adjust the alignment of objects with respect to 

each other using this tool.



We can use Guides to help us 

align our work.

Go to View > Guides Manager…



1. To add a new 

horizontal guide, 

click the page 

symbol.

2. Type in “1 in”

3. A horizontal blue line 

has appeared at 1 in.

This is our guide!



An alternate way to

create a guide is to

click and drag from 

the ruler into the 

document.

You can delete guides in the 

Guide Manager or by dragging

them back to the ruler with the 

Move Tool [V].



We can change the settings so

objects will “snap” to the guide,

much like things do in

PowerPoint.

Go to View > Snapping Manager.



Check Enable snapping. Default

settings are okay. Click close.

Now when you move your text 

around, you can see that it will 

“snap” to the guide we made.

You can always disable snapping 

when you don’t need it, or

delete the guide.



Finishing touches



Use the Crop Tool [C]

to crop white space 

off our image.



Let’s check the size of 

our canvas.

Ctrl + Alt + C
1. Unlock the aspect-

ratio by clicking the 

lock

2. Let’s crop it to a 

nice round number, 

so 2.9 in the second 

box.

3. The anchor point 

tells Affinity where 

center the resizing.



Let’s check the size of 

our document.

Ctrl + Alt + I

We don’t need to 

change stuff here, 

but this is useful for 

downscaling or 

upscaling your 

image.



Blending modes



Our figure is done, 

but the background 

is boring. Let’s add 

some spice with

BLENDING MODES!



Let’s place the pasta 

picture again.

In the Layer panel, 

click on “Normal” and 

see how the image 

changes when you 

change the mode.

Pick the one you 

want. Experiment 

with how changing 

the opacity changes 

the image.



Put the new pasta 

layer underneath 

the bird but over 

the fill layer.
For extra experimenting, try 

changing the Blending mode 

of the gradient.

For scientific figures, I have 

my gradients default to 

“Normal” or “Multiply”



Saving and exporting files

1. For editable files, save as .aphoto or .psd.

2. To save an image file, go to File > Export

Most common image files

• PNG – Great for most things! My default, 

though photos in png can get quite large 

in file size. Also supports transparency.

• JPG – May introduce artifacts. Only 

recommended if you want to save space, 

and usually with photos rather than 

illustrations.

• TIF – Big files. Usually for print.



https://tapas.io/episode/188280



https://tapas.io/episode/188280



Congrats! Now you know some Affinity Photo/Photoshop basics 

and can make some rad scientific figures.


